MG-Cars.info

Welcome to our Site for MG, Triumph and Austin-Healey Car Information.

Parts

MG parts spares and accessories are available for MG T Series (TA, MG TB, MG TC, MG TD, MG TF), Magnette, MGA, Twin cam, MGB, MGBGT, MGC, MGC GT, MG Midget, Sprite and other MG models from British car spares company LBCarCo.

MG Midget and Sprite Technical - Fuel Pump Query

My 1971 1275 spluttered and died on way home from work on Friday. I suspect fuel-related problem as engine just lost power, rev counter only dropped slowly, and most electrics were renewed a few months ago. Pulled over, and engine would turn over, but only run for a second or two, then nothing. After a few minutes and several unsuccessful attempts to start, it suddenly fired up, and I got home ok.

Testing fuel pump today, I disconnected hose from carb and ran through a flexible pipe into a container. Pump seemed to work fine, but if I cut off the flow by squeezing the flexible pipe, the pump would stop.

But, when I released the restriction in the pipe, the pump didn't restart, even after a few minutes. Is this normal, or does it signify a fault with the pump?

To add to my confusion, it seemed that if I wiggled the fuel line, even though it's tightly clipped in place, the pump would re-start. I suspected a blockage in the line, so disconnected it from the pump, and blew air through.

Reconnected, and it's exactly same as before - ie pump stops if I restrict flow and doesn't re=start.

Any ideas, before I strip the pump?
Jonathan M

No ideas. Strip the pump. ;o)
Dave O'Neill 2

You don't say if it's an SU pump or something else, so I'll assume it is an SU.

Did you attempt the tried and trusted tactic of whacking the heelboard with your fist?

My guess FWIW is that you should have a look inside the pump. It sounds like increasing the load by pinching off the outlet might be increasing the internal temperature of the pump and causing it to stop, so a good coat of looking at and a cleanup of the points might be what it needs.

As to wiggling the fuel line getting it going, who knows? I'd guess at coincidence.

Good luck anyway.
Greybeard

If it's an SU pump, it should stop when the fuel line is blocked. That's what happens when the needle valves in the carb float chambers close, the back pressure stalling the pump. But it must start immediately the back pressure is removed otherwise you are only going to be able to drive as far as you can get on a float chamber-full. If yours won't restart, the pump is faulty. The original type has a sort of contact breaker in it, and it's possible that the points just need cleaning.
Mike Howlett

I agree and add to...

Id pull it and clean the points as suggested, but id also have look at the diaphragm also it could be leaking

But as mike said above... the SU is supposed to shut off and on as the float chamber needle closes off and back on filling the float chamber

Also check the ground wire from the pump, it could be just now starting to rust up and not making good contact, ... not out of bounds considering the location

Prop


Prop and the Blackhole Midget

if it's not the points then consider replacing it with an electronic version. No more whacking it with a hammer/screwdriver etc :>)
Jeremy Tickle

Good call Mike. I'd forgotten about the needle valve closing stopping the pump. I still favour giving the points a scrub.

And good points Prop.
Greybeard

One problem with the electronic version - if it does stop, a good 'whack' will not get it going again!
Dave O'Neill 2


Dave O'Neill 2, West Midlands, United Kingdom  


One problem with the electronic version - if it does stop, a good 'whack' will not get it going again!


Also... if you have an electrical fart, the whole pump is toast, where the orginal will just smile and keep right on working

Prop
Prop and the Blackhole Midget

"Also... if you have an electrical fart, the whole pump is toast, where the orginal will just smile and keep right on working"

..except this one isn't :)
Jeremy Tickle

Thanks for your replies. It sounds like the pump should definitely just restart once the pressure is released (which is what happens when the float level drops and allows fuel to flow). The pump works enough to kick in when the ignition is first switched on, but won't quite start when the flow has been restricted, and then released. As I have checked there is no blockage in the pipe, and the pump is ok once it has started, but just isn't quite able to start up again when the flow is released, it sounds like something sticking slightly in the pump itself. So,I'll take the pump off and see if I can locate the problem/check points etc and hopefully will be able to report back that I've fixed it.
Jonathan M

Jonathen,

Before you go to all that hassle, id check the electrical ground esp at the pump...

If the ground connection is corroding, id think you would get very similar symptoms like your discribing.

If there is no ground, it wont work, if you got perfect ground, it will work like a champ, if the ground is rusting/dirty then it will only work randomly and weak, and probably over heat the positive wire.

Lets face it, sticking a fuel pump in the wheel well, was definatly NOT the best idea BMC ever came up with.

Prop
Prop and the Blackhole Midget

That's a good suggestion Prop, I should have checked that. Removed pump yesterday, stripped it down, no obvious sign of anything wrong, so just cleaned contacts etc and put it back on. Unfortunately, just as I was attaching the flexible outlet hose, the 'banjo' broke - as the pump was heavily covered in black paint I hadn't realised they were made of brittle plastic but even so I wasn't applying much force.

So, I now need a banjo fitting, and hope that with a good clean up/good earth the pump will be fine, or if it still plays up, a new pump.
Jonathan M

You wont feel to much suction... these are low pressure pumps, they push out about 1.5 to 2 psi no more then 3 psi max or they will blow past the carb needles and wont allow the engine to run

I think your bango is a vent tube ?

0n mine its an aluminume tube from the gas tank and the plastic vent tube from the engine bay is disconnected at the pump

But I am a 1971 USA spec

Prop
Prop and the Blackhole Midget

I believe that Jonathan is referring to this...

Dave O'Neill 2

That's the one Dave. Got one on order - I was surprised you could get such a small part.
Jonathan M

You might find this relevant.

"Why do SU fuel pumps stop and start running while an aftermarket pump runs
continuously?
Most after market pumps, such as the Facet, run continuously due to their having a bypass valve
in them (this is how they regulate the outlet pressure). These pumps donít care if the fuel flow is
interrupted on either the inlet or outlet side, they just continue to chatter away happily regardless.
All SU fuel pumps, points style or all electronic will shut off, once the float bowls are full and
then only tick periodically as the fuel in the bowls is used up. SU fuel pumps will also stop if
there is a clog on the inlet side of the pump. When this occurs, bad things happen to the pump
(see the section on In line, high efficiency filters added to the inlet side of the pump to protect
them). In addition to stopping when the float bowl is full or the inlet line to the pump is clogged,
the SU fuel pump will stop if there is a clog on the outlet side of the pump, only in this case bad
things donít happen to the pump (just to the progression of your trip). To prevent unintended
stopping of the SU fuel pump as a result of clogs, either on the inlet or outlet side, keep your fuel
system clean and free from rust and sediment.
Revised Sept."

http://homepages.donobi.net/sufuelpumps/
Lawrence Slater

Quick update- refitted pump, cleaned connections etc, and works fine - seems to click faster than before Probably just needed a bit of TLC. Thanks all for your comments. Jonathan
Jonathan M

This thread was discussed between 09/08/2015 and 17/08/2015

MG Midget and Sprite Technical index

This thread is from the archives. Join the live MG Midget and Sprite Technical BBS now